What’s Vulnerable › Vulnerabilities
CVE-2013-0894
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2013-02-23 · updated 2026-06-16
- Weakness: CWE-120
Description
Buffer overflow in the vorbis_parse_setup_hdr_floors function in the Vorbis decoder in vorbisdec.c in libavcodec in FFmpeg through 1.1.3, as used in Google Chrome before 25.0.1364.97 on Windows and Linux and before 25.0.1364.99 on Mac OS X and other products, allows remote attackers to cause a denial of service (divide-by-zero error or out-of-bounds array access) or possibly have unspecified other impact via vectors involving a zero value for a bark map size.
Affected products
- Canonical Ubuntu Linux: 12.04, 12.10
- FFmpeg: through 1.1.3
- Google Chrome: before 25.0.1364.99; before 25.0.1364.97 — fixed in 25.0.1364.97, 25.0.1364.99
- Opensuse: 12.1, 12.2
How to fix
Upgrade to a fixed version: Google Chrome 25.0.1364.97, 25.0.1364.99. Check the vendor advisory for mitigations.
References
- http://git.chromium.org/gitweb/?p=chromium/deps/ffmpeg.git%3Ba=commit%3Bh=e1e70d9bb9852b7d099379afc95531a632a20ba5
- http://git.videolan.org/?p=ffmpeg.git%3Ba=commit%3Bh=2c16bf2de07c68513072bf3cc96401d2c6291a3e
- http://googlechromereleases.blogspot.com/2013/02/stable-channel-update_21.html
- http://lists.opensuse.org/opensuse-updates/2013-03/msg00045.html
- http://www.ubuntu.com/usn/USN-1790-1
- https://code.google.com/p/chromium/issues/detail?id=168473
- http://git.chromium.org/gitweb/?p=chromium/deps/ffmpeg.git%3Ba=commit%3Bh=e1e70d9bb9852b7d099379afc95531a632a20ba5
- http://git.videolan.org/?p=ffmpeg.git%3Ba=commit%3Bh=2c16bf2de07c68513072bf3cc96401d2c6291a3e
- http://googlechromereleases.blogspot.com/2013/02/stable-channel-update_21.html
- http://lists.opensuse.org/opensuse-updates/2013-03/msg00045.html
- http://www.ubuntu.com/usn/USN-1790-1
- https://code.google.com/p/chromium/issues/detail?id=168473
Get alerted when CVE-2013-0894 or the next vulnerability affects your stack