What’s Vulnerable › Vulnerabilities
CVE-2013-0913
- Severity: high (CVSS 7.2 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2013-03-18 · updated 2026-06-16
- Weakness: CWE-189
Description
Integer overflow in drivers/gpu/drm/i915/i915_gem_execbuffer.c in the i915 driver in the Direct Rendering Manager (DRM) subsystem in the Linux kernel through 3.8.3, as used in Google Chrome OS before 25.0.1364.173 and other products, allows local users to cause a denial of service (heap-based buffer overflow) or possibly have unspecified other impact via a crafted application that triggers many relocation copies, and potentially leads to a race condition.
Affected products
- Linux kernel: from 2.6.37 before 3.0.71; from 3.1 before 3.2.42; from 3.3 before 3.4.38; from 3.5 before 3.8.5 — fixed in 3.0.71, 3.2.42, 3.4.38, 3.8.5
- Opensuse: 11.4, 12.1
How to fix
Upgrade to a fixed version: Linux kernel 3.0.71, 3.2.42, 3.4.38, 3.8.5. Check the vendor advisory for mitigations.
References
- http://git.chromium.org/gitweb/?p=chromiumos/third_party/kernel.git%3Ba=commit%3Bh=c79efdf2b7f68f985922a8272d64269ecd490477
- http://googlechromereleases.blogspot.com/2013/03/stable-channel-update-for-chrome-os_15.html
- http://lists.opensuse.org/opensuse-security-announce/2013-05/msg00018.html
- http://lists.opensuse.org/opensuse-security-announce/2013-06/msg00005.html
- http://openwall.com/lists/oss-security/2013/03/11/6
- http://openwall.com/lists/oss-security/2013/03/13/9
- http://openwall.com/lists/oss-security/2013/03/14/22
- http://rhn.redhat.com/errata/RHSA-2013-0744.html
- http://www.ubuntu.com/usn/USN-1809-1
- http://www.ubuntu.com/usn/USN-1811-1
- http://www.ubuntu.com/usn/USN-1812-1
- http://www.ubuntu.com/usn/USN-1813-1
Get alerted when CVE-2013-0913 or the next vulnerability affects your stack