What’s Vulnerable › Vulnerabilities
CVE-2013-10023: Editorial Calendar Plugin edcal.php edcal_filter_where sql injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-08 · updated 2026-06-16
- Weakness: CWE-89
Description
A vulnerability was found in Editorial Calendar Plugin up to 2.6 on WordPress. It has been declared as critical. Affected by this vulnerability is the function edcal_filter_where of the file edcal.php. The manipulation of the argument edcal_startDate/edcal_endDate leads to sql injection. The attack can be launched remotely. Upgrading to version 2.7 is able to address this issue. The patch is named a9277f13781187daee760b4dfd052b1b68e101cc. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-225151.
Affected products
- Editorial Calendar Plugin: before 2.7 — fixed in 2.7
How to fix
Upgrade to a fixed version: Editorial Calendar Plugin 2.7. Check the vendor advisory for mitigations.
References
- https://github.com/wp-plugins/editorial-calendar/commit/a9277f13781187daee760b4dfd052b1b68e101cc
- https://github.com/wp-plugins/editorial-calendar/releases/tag/2.7
- https://vuldb.com/?ctiid.225151
- https://vuldb.com/?id.225151
- https://github.com/wp-plugins/editorial-calendar/commit/a9277f13781187daee760b4dfd052b1b68e101cc
- https://github.com/wp-plugins/editorial-calendar/releases/tag/2.7
- https://vuldb.com/?ctiid.225151
- https://vuldb.com/?id.225151
Get alerted when CVE-2013-10023 or the next vulnerability affects your stack