What’s Vulnerable › Vulnerabilities
CVE-2013-10031: Plack::Middleware::Session versions before 0.17 for Perl may be vulnerable to HMAC comparison timing attacks
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-09 · updated 2026-06-16
- Weakness: CWE-1254
Description
Plack-Middleware-Session versions before 0.17 may be vulnerable to HMAC comparison timing attacks
Affected products
- Plack-Middleware-Session: before 0.17 — fixed in 0.17
How to fix
Upgrade to a fixed version: Plack-Middleware-Session 0.17. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2013-10031 or the next vulnerability affects your stack