What’s Vulnerable › Vulnerabilities
CVE-2013-1640
- Severity: critical (CVSS 9.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2013-03-20 · updated 2026-06-16
Description
The (1) template and (2) inline_template functions in the master server in Puppet before 2.6.18, 2.7.x before 2.7.21, and 3.1.x before 3.1.1, and Puppet Enterprise before 1.2.7 and 2.7.x before 2.7.2 allows remote authenticated users to execute arbitrary code via a crafted catalog request.
Affected products
- Canonical Ubuntu Linux: 11.10, 12.04, 12.10
- Puppet Agent: before 2.6.18; from 2.7.0 before 2.7.21; 3.1.0 — fixed in 2.6.18, 2.7.21
- Puppet Enterprise: before 1.2.7; 2.7.0, 2.7.1 — fixed in 1.2.7
How to fix
Upgrade to a fixed version: Puppet Agent 2.6.18, 2.7.21; Puppet Enterprise 1.2.7. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2013-04/msg00004.html
- http://lists.opensuse.org/opensuse-updates/2013-04/msg00056.html
- http://rhn.redhat.com/errata/RHSA-2013-0710.html
- http://secunia.com/advisories/52596
- http://ubuntu.com/usn/usn-1759-1
- http://www.debian.org/security/2013/dsa-2643
- https://puppetlabs.com/security/cve/cve-2013-1640/
- http://lists.opensuse.org/opensuse-security-announce/2013-04/msg00004.html
- http://lists.opensuse.org/opensuse-updates/2013-04/msg00056.html
- http://rhn.redhat.com/errata/RHSA-2013-0710.html
- http://secunia.com/advisories/52596
- http://ubuntu.com/usn/usn-1759-1
Get alerted when CVE-2013-1640 or the next vulnerability affects your stack