What’s Vulnerable › Vulnerabilities
CVE-2013-1753
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-03-11 · updated 2026-06-16
Description
The gzip_decode function in the xmlrpc client library in Python 3.4 and earlier allows remote attackers to cause a denial of service (memory consumption) via a crafted HTTP request.
Affected products
- Python: from 2.7.0 before 2.7.9; from 3.2.0 before 3.2.6; from 3.3.0 before 3.3.6; from 3.4.0 before 3.4.3 — fixed in 2.7.9, 3.2.6, 3.3.6, 3.4.3
How to fix
Upgrade to a fixed version: Python 2.7.9, 3.2.6, 3.3.6, 3.4.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2013-1753 or the next vulnerability affects your stack