What’s Vulnerable › Vulnerabilities
CVE-2013-1763
- Severity: high (CVSS 7.2 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2013-02-28 · updated 2026-06-16
- Weakness: CWE-20
Description
Array index error in the __sock_diag_rcv_msg function in net/core/sock_diag.c in the Linux kernel before 3.7.10 allows local users to gain privileges via a large family value in a Netlink message.
Affected products
- Linux kernel: from 3.3 before 3.4.34; from 3.5 before 3.7.10; from 3.8 before 3.8.1 — fixed in 3.4.34, 3.7.10, 3.8.1
How to fix
Upgrade to a fixed version: Linux kernel 3.4.34, 3.7.10, 3.8.1. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=6e601a53566d84e1ffd25e7b6fe0b6894ffd79c0
- http://lists.opensuse.org/opensuse-security-announce/2013-03/msg00004.html
- http://openwall.com/lists/oss-security/2013/02/25/12
- http://www.exploit-db.com/exploits/24555
- http://www.exploit-db.com/exploits/24746
- http://www.exploit-db.com/exploits/33336
- http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.7.10
- http://www.mandriva.com/security/advisories?name=MDVSA-2013:176
- http://www.openwall.com/lists/oss-security/2013/02/24/3
- http://www.ubuntu.com/usn/USN-1749-1
- http://www.ubuntu.com/usn/USN-1750-1
- http://www.ubuntu.com/usn/USN-1751-1
Get alerted when CVE-2013-1763 or the next vulnerability affects your stack