What’s Vulnerable › Vulnerabilities
CVE-2013-1860
- Severity: medium (CVSS 6.9 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2013-03-22 · updated 2026-06-16
- Weakness: CWE-119
Description
Heap-based buffer overflow in the wdm_in_callback function in drivers/usb/class/cdc-wdm.c in the Linux kernel before 3.8.4 allows physically proximate attackers to cause a denial of service (system crash) or possibly execute arbitrary code via a crafted cdc-wdm USB device.
Affected products
- Canonical Ubuntu Linux: 10.04, 12.04, 12.10
- Linux kernel: before 3.0.70; from 3.1 before 3.2.41; from 3.3 before 3.4.37; from 3.5 before 3.8.4 — fixed in 3.0.70, 3.2.41, 3.4.37, 3.8.4
How to fix
Upgrade to a fixed version: Linux kernel 3.0.70, 3.2.41, 3.4.37, 3.8.4. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=c0f5ecee4e741667b2493c742b60b6218d40b3aa
- http://rhn.redhat.com/errata/RHSA-2014-0328.html
- http://rhn.redhat.com/errata/RHSA-2014-0339.html
- http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.8.4
- http://www.mandriva.com/security/advisories?name=MDVSA-2013:176
- http://www.openwall.com/lists/oss-security/2013/03/15/3
- http://www.securityfocus.com/bid/58510
- http://www.ubuntu.com/usn/USN-1809-1
- http://www.ubuntu.com/usn/USN-1811-1
- http://www.ubuntu.com/usn/USN-1812-1
- http://www.ubuntu.com/usn/USN-1813-1
- http://www.ubuntu.com/usn/USN-1814-1
Get alerted when CVE-2013-1860 or the next vulnerability affects your stack