What’s Vulnerable › Vulnerabilities
CVE-2013-1861
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 18.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2013-03-28 · updated 2026-06-16
- Weakness: CWE-119
Description
MariaDB 5.5.x before 5.5.30, 5.3.x before 5.3.13, 5.2.x before 5.2.15, and 5.1.x before 5.1.68, and Oracle MySQL 5.1.69 and earlier, 5.5.31 and earlier, and 5.6.11 and earlier allows remote attackers to cause a denial of service (crash) via a crafted geometry feature that specifies a large number of points, which is not properly handled when processing the binary representation of this feature, related to a numeric calculation error.
Affected products
- Canonical Ubuntu Linux: 10.04, 12.04, 12.10, 13.04
- Debian Linux: 7.0
- MariaDB: from 5.5.0 before 5.5.32; from 10.0.0 before 10.0.4 — fixed in 10.0.4, 5.5.32
- Opensuse: 11.4, 12.2, 12.3
- MySQL Server: from 5.1.0 through 5.1.69; from 5.5.0 through 5.5.31; from 5.6.0 through 5.6.11
- Red Hat Enterprise Linux: 5, 6.0
- SUSE Linux Enterprise Server 15 SP1: 11-sp3
- SUSE Linux Enterprise Server: 11-sp3
- SUSE Linux Enterprise Software Development Kit: 11-sp3
How to fix
Upgrade to a fixed version: MariaDB 10.0.4, 5.5.32. Check the vendor advisory for mitigations.
References
- http://lists.askmonty.org/pipermail/commits/2013-March/004371.html
- http://lists.opensuse.org/opensuse-security-announce/2013-08/msg00022.html
- http://lists.opensuse.org/opensuse-security-announce/2013-10/msg00001.html
- http://lists.opensuse.org/opensuse-updates/2013-08/msg00024.html
- http://lists.opensuse.org/opensuse-updates/2013-09/msg00008.html
- http://seclists.org/oss-sec/2013/q1/671
- http://secunia.com/advisories/52639
- http://secunia.com/advisories/54300
- http://security.gentoo.org/glsa/glsa-201409-04.xml
- http://www.debian.org/security/2013/dsa-2818
- http://www.oracle.com/technetwork/topics/security/cpujuly2013-1899826.html
- http://www.osvdb.org/91415
Get alerted when CVE-2013-1861 or the next vulnerability affects your stack