What’s Vulnerable › Vulnerabilities
CVE-2013-1889
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-08 · updated 2026-06-16
- Weakness: CWE-20
Description
mod_ruid2 before 0.9.8 improperly handles file descriptors which allows remote attackers to bypass security using a CGI script to break out of the chroot.
Affected products
- libapache2-mod-ruid2: before 0.9.8 — fixed in 0.9.8
How to fix
Upgrade to a fixed version: libapache2-mod-ruid2 0.9.8. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2013/03/23/1
- https://exchange.xforce.ibmcloud.com/vulnerabilities/83035
- https://security-tracker.debian.org/tracker/CVE-2013-1889
- https://sourceforge.net/p/mod-ruid/mailman/mod-ruid-announce/thread/514C503E.4020109%40users.sourceforge.net/
- http://www.openwall.com/lists/oss-security/2013/03/23/1
- https://exchange.xforce.ibmcloud.com/vulnerabilities/83035
- https://security-tracker.debian.org/tracker/CVE-2013-1889
- https://sourceforge.net/p/mod-ruid/mailman/mod-ruid-announce/thread/514C503E.4020109%40users.sourceforge.net/
Get alerted when CVE-2013-1889 or the next vulnerability affects your stack