What’s Vulnerable › Vulnerabilities
CVE-2013-1915
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2013-04-25 · updated 2026-06-16
- Weakness: CWE-611
Description
ModSecurity before 2.7.3 allows remote attackers to read arbitrary files, send HTTP requests to intranet servers, or cause a denial of service (CPU and memory consumption) via an XML external entity declaration in conjunction with an entity reference, aka an XML External Entity (XXE) vulnerability.
Affected products
- Debian Linux: 6.0, 7.0
- Fedoraproject Fedora: 17, 18, 19
- Opensuse: 11.4, 12.2, 12.3
- Trustwave Modsecurity: before 2.7.3 — fixed in 2.7.3
How to fix
Upgrade to a fixed version: Trustwave Modsecurity 2.7.3. Check the vendor advisory for mitigations.
References
- http://lists.fedoraproject.org/pipermail/package-announce/2013-April/101898.html
- http://lists.fedoraproject.org/pipermail/package-announce/2013-April/101911.html
- http://lists.fedoraproject.org/pipermail/package-announce/2013-April/102616.html
- http://lists.opensuse.org/opensuse-updates/2013-08/msg00020.html
- http://lists.opensuse.org/opensuse-updates/2013-08/msg00025.html
- http://lists.opensuse.org/opensuse-updates/2013-08/msg00031.html
- http://secunia.com/advisories/52847
- http://secunia.com/advisories/52977
- http://www.debian.org/security/2013/dsa-2659
- http://www.mandriva.com/security/advisories?name=MDVSA-2013:156
- http://www.openwall.com/lists/oss-security/2013/04/03/7
- http://www.securityfocus.com/bid/58810
Get alerted when CVE-2013-1915 or the next vulnerability affects your stack