What’s Vulnerable › Vulnerabilities
CVE-2013-1951
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-31 · updated 2026-06-16
- Weakness: CWE-79
Description
A cross-site scripting (XSS) vulnerability in MediaWiki before 1.19.5 and 1.20.x before 1.20.4 and allows remote attackers to inject arbitrary web script or HTML via Lua function names.
Affected products
- Debian Linux: 9.0, 10.0
- Wikimedia Foundation MediaWiki: before 1.19.5; from 1.20.0 before 1.20.4 — fixed in 1.19.5, 1.20.4
How to fix
Upgrade to a fixed version: Wikimedia Foundation MediaWiki 1.19.5, 1.20.4. Check the vendor advisory for mitigations.
References
- http://lists.fedoraproject.org/pipermail/package-announce/2013-April/104022.html
- http://lists.fedoraproject.org/pipermail/package-announce/2013-April/104027.html
- http://security.gentoo.org/glsa/glsa-201310-21.xml
- http://www.openwall.com/lists/oss-security/2013/04/16/12
- http://www.securityfocus.com/bid/59077
- https://bugs.gentoo.org/show_bug.cgi?id=CVE-2013-1951
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2013-1951
- https://phabricator.wikimedia.org/T48084
- https://security-tracker.debian.org/tracker/CVE-2013-1951
- http://lists.fedoraproject.org/pipermail/package-announce/2013-April/104022.html
- http://lists.fedoraproject.org/pipermail/package-announce/2013-April/104027.html
- http://security.gentoo.org/glsa/glsa-201310-21.xml
Get alerted when CVE-2013-1951 or the next vulnerability affects your stack