What’s Vulnerable › Vulnerabilities

CVE-2013-1965

Description

Apache Struts Showcase App 2.0.0 through 2.3.13, as used in Struts 2 before 2.3.14.3, allows remote attackers to execute arbitrary OGNL code via a crafted parameter name that is not properly handled when invoking a redirect.

Affected products

How to fix

Upgrade to a fixed version: Apache Struts 2.3.14.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2013-1965 or the next vulnerability affects your stack