What’s Vulnerable › Vulnerabilities
CVE-2013-1966
- Severity: critical (CVSS 9.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 73.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2013-07-10 · updated 2026-06-16
- Weakness: CWE-94
Description
Apache Struts 2 before 2.3.14.2 allows remote attackers to execute arbitrary OGNL code via a crafted request that is not properly handled when using the includeParams attribute in the (1) URL or (2) A tag.
Affected products
- Apache Struts: from 2.0.0 before 2.3.14.1 — fixed in 2.3.14.1
How to fix
Upgrade to a fixed version: Apache Struts 2.3.14.1. Check the vendor advisory for mitigations.
References
- http://struts.apache.org/development/2.x/docs/s2-013.html
- http://www.securityfocus.com/bid/60166
- https://bugzilla.redhat.com/show_bug.cgi?id=967656
- https://cwiki.apache.org/confluence/display/WW/S2-013
- http://struts.apache.org/development/2.x/docs/s2-013.html
- http://www.securityfocus.com/bid/60166
- https://bugzilla.redhat.com/show_bug.cgi?id=967656
- https://cwiki.apache.org/confluence/display/WW/S2-013
Get alerted when CVE-2013-1966 or the next vulnerability affects your stack