What’s Vulnerable › Vulnerabilities
CVE-2013-2094: Linux Kernel Privilege Escalation Vulnerability
- Severity: high (CVSS 7.2 v2.0)
- Exploited in the wild: yes — in CISA KEV since 2022-09-15
- EPSS: 47.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2013-05-14 · updated 2026-06-16
- Weakness: CWE-189
Description
The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9 uses an incorrect integer data type, which allows local users to gain privileges via a crafted perf_event_open system call.
Affected products
- Linux kernel: before 3.0.75; from 3.1 before 3.2.45; from 3.3 before 3.4.42; from 3.5 before 3.8.9 — fixed in 3.0.75, 3.2.45, 3.4.42, 3.8.9
How to fix
Upgrade to a fixed version: Linux kernel 3.0.75, 3.2.45, 3.4.42, 3.8.9. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=8176cced706b5e5d15887584150764894e94e02f
- http://lists.centos.org/pipermail/centos-announce/2013-May/019729.html
- http://lists.centos.org/pipermail/centos-announce/2013-May/019733.html
- http://lists.opensuse.org/opensuse-security-announce/2013-05/msg00008.html
- http://lists.opensuse.org/opensuse-security-announce/2013-05/msg00018.html
- http://lists.opensuse.org/opensuse-security-announce/2013-06/msg00005.html
- http://lists.opensuse.org/opensuse-security-announce/2013-06/msg00009.html
- http://lists.opensuse.org/opensuse-security-announce/2013-06/msg00017.html
- http://lkml.indiana.edu/hypermail/linux/kernel/1304.1/03652.html
- http://lkml.indiana.edu/hypermail/linux/kernel/1304.1/03976.html
- http://lkml.indiana.edu/hypermail/linux/kernel/1304.1/04302.html
- http://news.ycombinator.com/item?id=5703758
Get alerted when CVE-2013-2094 or the next vulnerability affects your stack