What’s Vulnerable › Vulnerabilities
CVE-2013-2120
- Severity: high (CVSS 8.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-02-11 · updated 2026-06-16
- Weakness: CWE-287
Description
The %{password(...)} macro in pastemacroexpander.cpp in the KDE Paste Applet before 4.10.5 in kdeplasma-addons does not properly generate passwords, which allows context-dependent attackers to bypass authentication via a brute-force attack.
Affected products
- KDE Paste Applet: before 4.10.5 — fixed in 4.10.5
How to fix
Upgrade to a fixed version: KDE Paste Applet 4.10.5. Check the vendor advisory for mitigations.
References
- http://archives.neohapsis.com/archives/bugtraq/2013-05/0114.html
- http://openwall.com/lists/oss-security/2013/05/28/5
- http://openwall.com/lists/oss-security/2013/05/29/6
- https://bugzilla.redhat.com/show_bug.cgi?id=969421
- https://projects.kde.org/projects/kde/kdeplasma-addons/repository/revisions/36a1fe49cb70f717c4a6e9eeee2c9186503a8dce
- http://archives.neohapsis.com/archives/bugtraq/2013-05/0114.html
- http://openwall.com/lists/oss-security/2013/05/28/5
- http://openwall.com/lists/oss-security/2013/05/29/6
- https://bugzilla.redhat.com/show_bug.cgi?id=969421
- https://projects.kde.org/projects/kde/kdeplasma-addons/repository/revisions/36a1fe49cb70f717c4a6e9eeee2c9186503a8dce
Get alerted when CVE-2013-2120 or the next vulnerability affects your stack