What’s Vulnerable › Vulnerabilities
CVE-2013-2135
- Severity: critical (CVSS 9.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 13.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2013-07-16 · updated 2026-06-16
- Weakness: CWE-94
Description
Apache Struts 2 before 2.3.14.3 allows remote attackers to execute arbitrary OGNL code via a request with a crafted value that contains both "${}" and "%{}" sequences, which causes the OGNL code to be evaluated twice.
Affected products
- Apache Struts: from 2.0.0 before 2.3.14.3 — fixed in 2.3.14.3
How to fix
Upgrade to a fixed version: Apache Struts 2.3.14.3. Check the vendor advisory for mitigations.
References
- http://struts.apache.org/development/2.x/docs/s2-015.html
- http://www.oracle.com/technetwork/topics/security/cpujan2014-1972949.html
- http://www.oracle.com/technetwork/topics/security/cpuoct2013-1899837.html
- http://www.securityfocus.com/bid/64758
- https://cwiki.apache.org/confluence/display/WW/S2-015
- http://struts.apache.org/development/2.x/docs/s2-015.html
- http://www.oracle.com/technetwork/topics/security/cpujan2014-1972949.html
- http://www.oracle.com/technetwork/topics/security/cpuoct2013-1899837.html
- http://www.securityfocus.com/bid/64758
- https://cwiki.apache.org/confluence/display/WW/S2-015
Get alerted when CVE-2013-2135 or the next vulnerability affects your stack