What’s Vulnerable › Vulnerabilities
CVE-2013-2233
- Severity: high (CVSS 7.4 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-05-04 · updated 2026-06-16
- Weakness: CWE-320
Description
Ansible before 1.2.1 makes it easier for remote attackers to conduct man-in-the-middle attacks by leveraging failure to cache SSH host keys.
Affected products
- Red Hat Ansible: before 1.2.1 — fixed in 1.2.1
How to fix
Upgrade to a fixed version: Red Hat Ansible 1.2.1. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2013/07/01/2
- http://www.openwall.com/lists/oss-security/2013/07/02/6
- https://bugzilla.redhat.com/show_bug.cgi?id=980821
- https://github.com/ansible/ansible/issues/857
- https://www.ansible.com/security
- http://www.openwall.com/lists/oss-security/2013/07/01/2
- http://www.openwall.com/lists/oss-security/2013/07/02/6
- https://bugzilla.redhat.com/show_bug.cgi?id=980821
- https://github.com/ansible/ansible/issues/857
- https://www.ansible.com/security
Get alerted when CVE-2013-2233 or the next vulnerability affects your stack