What’s Vulnerable › Vulnerabilities
CVE-2013-2596: Linux Kernel Integer Overflow Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2022-09-15
- EPSS: 3.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2013-04-13 · updated 2026-06-16
- Weakness: CWE-190
Description
Integer overflow in the fb_mmap function in drivers/video/fbmem.c in the Linux kernel before 3.8.9, as used in a certain Motorola build of Android 4.1.2 and other products, allows local users to create a read-write memory mapping for the entirety of kernel memory, and consequently gain privileges, via crafted /dev/graphics/fb0 mmap2 system calls, as demonstrated by the Motochopper pwn program.
Affected products
- Linux kernel: from 2.6.12 before 3.0.75; from 3.1 before 3.2.45; from 3.3 before 3.4.42; from 3.5 before 3.8.9 — fixed in 3.0.75, 3.2.45, 3.4.42, 3.8.9
- Motorola Android: 4.1.2
How to fix
Upgrade to a fixed version: Linux kernel 3.0.75, 3.2.45, 3.4.42, 3.8.9. Check the vendor advisory for mitigations.
References
- http://forum.xda-developers.com/showthread.php?t=2255491
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=b4cbb197c7e7a68dbad0d491242e3ca67420c13e
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=fc9bbca8f650e5f738af8806317c0a041a48ae4a
- http://kb.juniper.net/InfoCenter/index?page=content&id=JSA10761
- http://marc.info/?l=linux-kernel&m=136616837923938&w=2
- http://rhn.redhat.com/errata/RHSA-2015-0695.html
- http://rhn.redhat.com/errata/RHSA-2015-0782.html
- http://rhn.redhat.com/errata/RHSA-2015-0803.html
- http://www.droid-life.com/2013/04/09/root-method-released-for-droid-razr-hd-running-android-4-1-2-other-devices-too/
- http://www.droidrzr.com/index.php/topic/15208-root-motochopper-yet-another-android-root-exploit/
- http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.8.9
- http://www.mandriva.com/security/advisories?name=MDVSA-2013:176
Get alerted when CVE-2013-2596 or the next vulnerability affects your stack