What’s Vulnerable › Vulnerabilities
CVE-2013-2765
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 13.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2013-07-15 · updated 2026-06-16
- Weakness: CWE-476
Description
The ModSecurity module before 2.7.4 for the Apache HTTP Server allows remote attackers to cause a denial of service (NULL pointer dereference, process crash, and disk consumption) via a POST request with a large body and a crafted Content-Type header.
Affected products
- Opensuse: 11.4, 12.2, 12.3
- Trustwave Modsecurity: before 2.7.4 — fixed in 2.7.4
How to fix
Upgrade to a fixed version: Trustwave Modsecurity 2.7.4. Check the vendor advisory for mitigations.
References
- http://archives.neohapsis.com/archives/bugtraq/2013-05/0125.html
- http://lists.opensuse.org/opensuse-updates/2013-08/msg00020.html
- http://lists.opensuse.org/opensuse-updates/2013-08/msg00025.html
- http://lists.opensuse.org/opensuse-updates/2013-08/msg00031.html
- http://sourceforge.net/mailarchive/message.php?msg_id=30900019
- http://www.modsecurity.org/
- http://www.shookalabs.com/
- https://bugzilla.redhat.com/show_bug.cgi?id=967615
- https://github.com/SpiderLabs/ModSecurity/commit/0840b13612a0b7ef1ce7441cf811dcfc6b463fba
- https://github.com/shookalabs/exploits/blob/master/modsecurity_cve_2013_2765_check.py
- https://raw.github.com/SpiderLabs/ModSecurity/master/CHANGES
- http://archives.neohapsis.com/archives/bugtraq/2013-05/0125.html
Get alerted when CVE-2013-2765 or the next vulnerability affects your stack