What’s Vulnerable › Vulnerabilities
CVE-2013-2850
- Severity: high (CVSS 7.9 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2013-06-07 · updated 2026-06-16
- Weakness: CWE-119
Description
Heap-based buffer overflow in the iscsi_add_notunderstood_response function in drivers/target/iscsi/iscsi_target_parameters.c in the iSCSI target subsystem in the Linux kernel through 3.9.4 allows remote attackers to cause a denial of service (memory corruption and OOPS) or possibly execute arbitrary code via a long key that is not properly handled during construction of an error-response packet.
Affected products
- Linux kernel: from 3.1 before 3.2.47; from 3.3 before 3.4.48; from 3.5 before 3.9.5 — fixed in 3.2.47, 3.4.48, 3.9.5
How to fix
Upgrade to a fixed version: Linux kernel 3.2.47, 3.4.48, 3.9.5. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=cea4dcfdad926a27a18e188720efe0f2c9403456
- http://lists.opensuse.org/opensuse-security-announce/2013-05/msg00017.html
- http://lists.opensuse.org/opensuse-security-announce/2013-06/msg00011.html
- http://lists.opensuse.org/opensuse-security-announce/2013-06/msg00017.html
- http://lists.opensuse.org/opensuse-security-announce/2013-06/msg00018.html
- http://www.openwall.com/lists/oss-security/2013/06/01/2
- http://www.ubuntu.com/usn/USN-1844-1
- http://www.ubuntu.com/usn/USN-1845-1
- http://www.ubuntu.com/usn/USN-1846-1
- http://www.ubuntu.com/usn/USN-1847-1
- https://bugzilla.redhat.com/show_bug.cgi?id=968036
- https://github.com/torvalds/linux/commit/cea4dcfdad926a27a18e188720efe0f2c9403456
Get alerted when CVE-2013-2850 or the next vulnerability affects your stack