What’s Vulnerable › Vulnerabilities
CVE-2013-3301
- Severity: high (CVSS 7.2 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2013-04-29 · updated 2026-06-16
Description
The ftrace implementation in the Linux kernel before 3.8.8 allows local users to cause a denial of service (NULL pointer dereference and system crash) or possibly have unspecified other impact by leveraging the CAP_SYS_ADMIN capability for write access to the (1) set_ftrace_pid or (2) set_graph_function file, and then making an lseek system call.
Affected products
- Linux kernel: from 3.1 before 3.2.44; from 3.3 before 3.4.49; from 3.5 before 3.8.8 — fixed in 3.2.44, 3.4.49, 3.8.8
- Red Hat Enterprise Linux: 6.0
- RedHat Enterprise Mrg: 2.0
- SUSE Linux Enterprise Server 15 SP1: 11-sp3
- SUSE Linux Enterprise High Availability Extension: 11-sp3
- SUSE Linux Enterprise Server: 11-sp3
How to fix
Upgrade to a fixed version: Linux kernel 3.2.44, 3.4.49, 3.8.8. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=6a76f8c0ab19f215af2a3442870eeb5f0e81998d
- http://lists.opensuse.org/opensuse-security-announce/2013-09/msg00003.html
- http://lists.opensuse.org/opensuse-updates/2013-12/msg00129.html
- http://rhn.redhat.com/errata/RHSA-2013-1051.html
- http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.8.8
- http://www.openwall.com/lists/oss-security/2013/04/15/1
- http://www.ubuntu.com/usn/USN-1834-1
- http://www.ubuntu.com/usn/USN-1835-1
- http://www.ubuntu.com/usn/USN-1836-1
- http://www.ubuntu.com/usn/USN-1838-1
- https://bugzilla.redhat.com/show_bug.cgi?id=952197
- https://github.com/torvalds/linux/commit/6a76f8c0ab19f215af2a3442870eeb5f0e81998d
Get alerted when CVE-2013-3301 or the next vulnerability affects your stack