What’s Vulnerable › Vulnerabilities
CVE-2013-3565
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-01-31 · updated 2026-06-16
- Weakness: CWE-79
Description
Multiple cross-site scripting (XSS) vulnerabilities in the HTTP Interface in VideoLAN VLC Media Player before 2.0.7 allow remote attackers to inject arbitrary web script or HTML via the (1) command parameter to requests/vlm_cmd.xml, (2) dir parameter to requests/browse.xml, or (3) URI in a request, which is returned in an error message through share/lua/intf/http.lua.
Affected products
- Opensuse: 13.1
- VideoLAN VLC: before 2.0.7 — fixed in 2.0.7
How to fix
Upgrade to a fixed version: VideoLAN VLC 2.0.7. Check the vendor advisory for mitigations.
References
- http://git.videolan.org/gitweb.cgi/vlc.git/?p=vlc.git%3Ba=commitdiff%3Bh=bf02b8dd211d5a52aa301a9a2ff4e73ed8195881
- http://lists.opensuse.org/opensuse-updates/2014-03/msg00001.html
- http://www.videolan.org/developers/vlc-branch/NEWS
- https://www3.trustwave.com/spiderlabs/advisories/TWSL2013-007.txt
- http://git.videolan.org/gitweb.cgi/vlc.git/?p=vlc.git%3Ba=commitdiff%3Bh=bf02b8dd211d5a52aa301a9a2ff4e73ed8195881
- http://lists.opensuse.org/opensuse-updates/2014-03/msg00001.html
- http://www.videolan.org/developers/vlc-branch/NEWS
- https://www3.trustwave.com/spiderlabs/advisories/TWSL2013-007.txt
Get alerted when CVE-2013-3565 or the next vulnerability affects your stack