What’s Vulnerable › Vulnerabilities
CVE-2013-4002
- Severity: high (CVSS 7.1 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 24.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2013-07-23 · updated 2026-06-16
Description
XMLscanner.java in Apache Xerces2 Java Parser before 2.12.0, as used in the Java Runtime Environment (JRE) in IBM Java 5.0 before 5.0 SR16-FP3, 6 before 6 SR14, 6.0.1 before 6.0.1 SR6, and 7 before 7 SR5 as well as Oracle Java SE 7u40 and earlier, Java SE 6u60 and earlier, Java SE 5.0u51 and earlier, JRockit R28.2.8 and earlier, JRockit R27.7.6 and earlier, Java SE Embedded 7u40 and earlier, and possibly other products allows remote attackers to cause a denial of service via vectors related to XML attribute names.
Affected products
- Apache Xerces2 Java: from 2.4.0 before 2.12.0 — fixed in 2.12.0
- Canonical Ubuntu Linux: 10.04, 12.04, 12.10, 13.04, 13.10
- IBM Host On-Demand: 11.0, 11.0.1, 11.0.2, 11.0.3, 11.0.4, 11.0.5 (+5)
- IBM Java: 5.0.0.0, 5.0.11.0, 5.0.11.1, 5.0.11.2, 5.0.12.0, 5.0.12.1 (+37)
- IBM Sterling B2B Integrator: 5.2.4, 5.1, 5.2
- IBM Sterling File Gateway: 2.1, 2.2
- IBM Tivoli Application Dependency Discovery Manager: 7.2.2
- Opensuse: 12.2, 12.3
- Oracle Java SE: 1.5.0-update51, 1.6.0-update60, 1.7.0-update40
- Oracle Java SE: 1.5.0-update51, 1.6.0-update60, 1.7.0-update40
- Oracle JRockit: from r27.7.0 through r27.7.6; from r28.0.0 through r28.2.8
- SUSE Linux Enterprise Server 15 SP1: 10-sp4, 11-sp3
- SUSE Linux Enterprise Java: 10-sp4, 11-sp2, 11-sp3
- SUSE Linux Enterprise Sdk: 11-sp2, 11-sp3
- SUSE Linux Enterprise Server: 9, 10-sp3, 10-sp4, 11-sp2, 11-sp3
How to fix
Upgrade to a fixed version: Apache Xerces2 Java 2.12.0. Check the vendor advisory for mitigations.
References
- http://lists.apple.com/archives/security-announce/2013/Oct/msg00001.html
- http://lists.opensuse.org/opensuse-security-announce/2013-07/msg00026.html
- http://lists.opensuse.org/opensuse-security-announce/2013-07/msg00027.html
- http://lists.opensuse.org/opensuse-security-announce/2013-07/msg00028.html
- http://lists.opensuse.org/opensuse-security-announce/2013-07/msg00029.html
- http://lists.opensuse.org/opensuse-security-announce/2013-08/msg00000.html
- http://lists.opensuse.org/opensuse-security-announce/2013-08/msg00003.html
- http://lists.opensuse.org/opensuse-security-announce/2013-11/msg00010.html
- http://lists.opensuse.org/opensuse-updates/2013-11/msg00023.html
- http://marc.info/?l=bugtraq&m=138674031212883&w=2
- http://marc.info/?l=bugtraq&m=138674073720143&w=2
- http://rhn.redhat.com/errata/RHSA-2013-1059.html
Get alerted when CVE-2013-4002 or the next vulnerability affects your stack