What’s Vulnerable › Vulnerabilities
CVE-2013-4113
- Severity: medium (CVSS 6.8 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2013-07-13 · updated 2026-06-16
- Weakness: CWE-787
Description
ext/xml/xml.c in PHP before 5.3.27 does not properly consider parsing depth, which allows remote attackers to cause a denial of service (heap memory corruption) or possibly have unspecified other impact via a crafted document that is processed by the xml_parse_into_struct function.
Affected products
- PHP: from 5.3.0 before 5.3.27; from 5.4.0 before 5.4.18 — fixed in 5.3.27, 5.4.18
How to fix
Upgrade to a fixed version: PHP 5.3.27, 5.4.18. Check the vendor advisory for mitigations.
References
- http://git.php.net/?p=php-src.git%3Ba=commit%3Bh=7d163e8a0880ae8af2dd869071393e5dc07ef271
- http://lists.opensuse.org/opensuse-security-announce/2013-07/msg00034.html
- http://lists.opensuse.org/opensuse-security-announce/2013-08/msg00006.html
- http://lists.opensuse.org/opensuse-security-announce/2013-08/msg00007.html
- http://php.net/ChangeLog-5.php
- http://php.net/archive/2013.php#id2013-07-11-1
- http://rhn.redhat.com/errata/RHSA-2013-1049.html
- http://rhn.redhat.com/errata/RHSA-2013-1050.html
- http://rhn.redhat.com/errata/RHSA-2013-1061.html
- http://rhn.redhat.com/errata/RHSA-2013-1062.html
- http://rhn.redhat.com/errata/RHSA-2013-1063.html
- http://secunia.com/advisories/54071
Get alerted when CVE-2013-4113 or the next vulnerability affects your stack