What’s Vulnerable › Vulnerabilities
CVE-2013-4116
- Severity: low (CVSS 3.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2014-04-22 · updated 2026-06-16
- Weakness: CWE-59
Description
lib/npm.js in Node Packaged Modules (npm) before 1.3.3 allows local users to overwrite arbitrary files via a symlink attack on temporary files with predictable names that are created when unpacking archives.
Affected products
- Node Packaged Modules Project Node Packaged Modules: before 1.3.3 — fixed in 1.3.3
How to fix
Upgrade to a fixed version: Node Packaged Modules Project Node Packaged Modules 1.3.3. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2013/07/10/17
- http://www.openwall.com/lists/oss-security/2013/07/11/9
- http://www.securityfocus.com/bid/61083
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=715325
- https://bugzilla.redhat.com/show_bug.cgi?id=983917
- https://exchange.xforce.ibmcloud.com/vulnerabilities/87141
- https://github.com/npm/npm/commit/f4d31693
- https://github.com/npm/npm/issues/3635
- http://www.openwall.com/lists/oss-security/2013/07/10/17
- http://www.openwall.com/lists/oss-security/2013/07/11/9
- http://www.securityfocus.com/bid/61083
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=715325
Get alerted when CVE-2013-4116 or the next vulnerability affects your stack