What’s Vulnerable › Vulnerabilities
CVE-2013-4225
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-02-11 · updated 2026-06-16
- Weakness: CWE-79
Description
The RESTful Web Services (restws) module 7.x-1.x before 7.x-1.4 and 7.x-2.x before 7.x-2.1 for Drupal does not properly restrict access to entity write operations, which makes it easier for remote authenticated users with the "access resource node" and "create page content" permissions (or equivalents) to conduct cross-site scripting (XSS) or execute arbitrary PHP code via a crafted text field.
Affected products
- RESTful Web Services: from 7.x-1.0 before 7.x-1.4; from 7.x-2.0 before 7.x-2.1; 7.x-2.x-dev — fixed in 7.x-1.4, 7.x-2.1
How to fix
Upgrade to a fixed version: RESTful Web Services 7.x-1.4, 7.x-2.1. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2013/08/10/1
- https://drupal.org/node/2059591
- https://drupal.org/node/2059593
- https://drupal.org/node/2059603
- http://www.openwall.com/lists/oss-security/2013/08/10/1
- https://drupal.org/node/2059591
- https://drupal.org/node/2059593
- https://drupal.org/node/2059603
Get alerted when CVE-2013-4225 or the next vulnerability affects your stack