What’s Vulnerable › Vulnerabilities
CVE-2013-4288
- Severity: high (CVSS 7.2 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2013-10-03 · updated 2026-06-16
- Weakness: CWE-362
Description
Race condition in PolicyKit (aka polkit) allows local users to bypass intended PolicyKit restrictions and gain privileges by starting a setuid or pkexec process before the authorization check is performed, related to (1) the polkit_unix_process_new API function, (2) the dbus API, or (3) the --process (unix-process) option for authorization to pkcheck.
Affected products
- Canonical Ubuntu Linux: 10.04, 12.04, 12.10, 13.04
- Opensuse: 12.2, 12.3
- Polkit Project Polkit: before 0.112.1 — fixed in 0.112.1
- Red Hat Enterprise Linux: 6.0
How to fix
Upgrade to a fixed version: Polkit Project Polkit 0.112.1. Check the vendor advisory for mitigations.
References
- http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=1002375
- http://lists.opensuse.org/opensuse-updates/2013-10/msg00004.html
- http://lists.opensuse.org/opensuse-updates/2013-10/msg00005.html
- http://lists.opensuse.org/opensuse-updates/2013-10/msg00062.html
- http://lists.opensuse.org/opensuse-updates/2013-11/msg00000.html
- http://rhn.redhat.com/errata/RHSA-2013-1270.html
- http://rhn.redhat.com/errata/RHSA-2013-1460.html
- http://seclists.org/oss-sec/2013/q3/626
- http://www.openwall.com/lists/oss-security/2013/09/18/4
- http://www.ubuntu.com/usn/USN-1953-1
- http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=1002375
- http://lists.opensuse.org/opensuse-updates/2013-10/msg00004.html
Get alerted when CVE-2013-4288 or the next vulnerability affects your stack