What’s Vulnerable › Vulnerabilities
CVE-2013-4300
- Severity: high (CVSS 7.2 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2013-09-25 · updated 2026-06-16
- Weakness: CWE-264
Description
The scm_check_creds function in net/core/scm.c in the Linux kernel before 3.11 performs a capability check in an incorrect namespace, which allows local users to gain privileges via PID spoofing.
Affected products
- Linux kernel: from 3.8.6 before 3.9; 3.9-rc1, 3.9-rc2, 3.9-rc3, 3.9-rc4 — fixed in 3.9
How to fix
Upgrade to a fixed version: Linux kernel 3.9. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=d661684cf6820331feae71146c35da83d794467e
- http://www.openwall.com/lists/oss-security/2013/09/05/3
- http://www.ubuntu.com/usn/USN-1995-1
- http://www.ubuntu.com/usn/USN-1998-1
- https://bugzilla.redhat.com/show_bug.cgi?id=1004736
- https://github.com/torvalds/linux/commit/d661684cf6820331feae71146c35da83d794467e
- https://www.kernel.org/pub/linux/kernel/v3.x/patch-3.11.bz2
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=d661684cf6820331feae71146c35da83d794467e
- http://www.openwall.com/lists/oss-security/2013/09/05/3
- http://www.ubuntu.com/usn/USN-1995-1
- http://www.ubuntu.com/usn/USN-1998-1
- https://bugzilla.redhat.com/show_bug.cgi?id=1004736
Get alerted when CVE-2013-4300 or the next vulnerability affects your stack