What’s Vulnerable › Vulnerabilities
CVE-2013-4303
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-12-11 · updated 2026-06-16
- Weakness: CWE-79
Description
includes/libs/IEUrlExtension.php in the MediaWiki API in MediaWiki 1.19.x before 1.19.8, 1.20.x before 1.20.7, and 1.21.x before 1.21.2 does not properly detect extensions when there are an even number of "." (period) characters in a string, which allows remote attackers to conduct cross-site scripting (XSS) attacks via the siprop parameter in a query action to wiki/api.php.
Affected products
- Wikimedia Foundation MediaWiki: from 1.19.0 before 1.19.8; from 1.20.0 before 1.20.7; from 1.21.0 before 1.21.2 — fixed in 1.19.8, 1.20.7, 1.21.2
How to fix
Upgrade to a fixed version: Wikimedia Foundation MediaWiki 1.19.8, 1.20.7, 1.21.2. Check the vendor advisory for mitigations.
References
- http://lists.wikimedia.org/pipermail/mediawiki-announce/2013-September/000133.html
- http://seclists.org/oss-sec/2013/q3/553
- http://www.securityfocus.com/bid/62194
- https://bugzilla.wikimedia.org/show_bug.cgi?id=52746
- https://exchange.xforce.ibmcloud.com/vulnerabilities/86897
- http://lists.wikimedia.org/pipermail/mediawiki-announce/2013-September/000133.html
- http://seclists.org/oss-sec/2013/q3/553
- http://www.securityfocus.com/bid/62194
- https://bugzilla.wikimedia.org/show_bug.cgi?id=52746
- https://exchange.xforce.ibmcloud.com/vulnerabilities/86897
Get alerted when CVE-2013-4303 or the next vulnerability affects your stack