What’s Vulnerable › Vulnerabilities
CVE-2013-4389
- Severity: medium (CVSS 4.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2013-10-17 · updated 2026-06-16
- Weakness: CWE-134
Description
Multiple format string vulnerabilities in log_subscriber.rb files in the log subscriber component in Action Mailer in Ruby on Rails 3.x before 3.2.15 allow remote attackers to cause a denial of service via a crafted e-mail address that is improperly handled during construction of a log message.
Affected products
- Debian Linux: 7.0
- Opensuse: 12.2, 12.3, 13.1
- Ruby on Rails: from 3.0.0 before 3.2.15 — fixed in 3.2.15
How to fix
Upgrade to a fixed version: Ruby on Rails 3.2.15. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-updates/2013-12/msg00091.html
- http://lists.opensuse.org/opensuse-updates/2013-12/msg00094.html
- http://lists.opensuse.org/opensuse-updates/2014-01/msg00003.html
- http://www.debian.org/security/2014/dsa-2887
- http://www.debian.org/security/2014/dsa-2888
- https://groups.google.com/forum/message/raw?msg=ruby-security-ann/yvlR1Vx44c8/elKJkpO2KVgJ
- http://lists.opensuse.org/opensuse-updates/2013-12/msg00091.html
- http://lists.opensuse.org/opensuse-updates/2013-12/msg00094.html
- http://lists.opensuse.org/opensuse-updates/2014-01/msg00003.html
- http://www.debian.org/security/2014/dsa-2887
- http://www.debian.org/security/2014/dsa-2888
- https://groups.google.com/forum/message/raw?msg=ruby-security-ann/yvlR1Vx44c8/elKJkpO2KVgJ
Get alerted when CVE-2013-4389 or the next vulnerability affects your stack