What’s Vulnerable › Vulnerabilities
CVE-2013-4475
- Severity: medium (CVSS 4.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 9.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2013-11-13 · updated 2026-06-16
- Weakness: CWE-264
Description
Samba 3.2.x through 3.6.x before 3.6.20, 4.0.x before 4.0.11, and 4.1.x before 4.1.1, when vfs_streams_depot or vfs_streams_xattr is enabled, allows remote attackers to bypass intended file restrictions by leveraging ACL differences between a file and an associated alternate data stream (ADS).
Affected products
- Canonical Ubuntu Linux: 10.04, 12.04, 12.10, 13.04, 13.10
- Debian Linux: 6.0, 7.0
- Samba: from 3.2.0 before 3.6.20; from 4.0.0 before 4.0.11; 4.1.0 — fixed in 3.6.20, 4.0.11
How to fix
Upgrade to a fixed version: Samba 3.6.20, 4.0.11. Check the vendor advisory for mitigations.
References
- http://lists.fedoraproject.org/pipermail/package-announce/2014-August/136864.html
- http://lists.opensuse.org/opensuse-security-announce/2014-01/msg00002.html
- http://lists.opensuse.org/opensuse-updates/2013-11/msg00083.html
- http://lists.opensuse.org/opensuse-updates/2013-11/msg00115.html
- http://lists.opensuse.org/opensuse-updates/2013-11/msg00117.html
- http://lists.opensuse.org/opensuse-updates/2013-12/msg00088.html
- http://rhn.redhat.com/errata/RHSA-2013-1806.html
- http://rhn.redhat.com/errata/RHSA-2014-0009.html
- http://secunia.com/advisories/56508
- http://security.gentoo.org/glsa/glsa-201502-15.xml
- http://www.debian.org/security/2013/dsa-2812
- http://www.samba.org/samba/history/samba-3.6.20.html
Get alerted when CVE-2013-4475 or the next vulnerability affects your stack