What’s Vulnerable › Vulnerabilities
CVE-2013-4559
- Severity: high (CVSS 7.6 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 10.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2013-11-20 · updated 2026-06-16
- Weakness: CWE-264
Description
lighttpd before 1.4.33 does not check the return value of the (1) setuid, (2) setgid, or (3) setgroups functions, which might cause lighttpd to run as root if it is restarted and allows remote attackers to gain privileges, as demonstrated by multiple calls to the clone function that cause setuid to fail when the user process limit is reached.
Affected products
- Debian Linux: 6.0, 7.0, 8.0
- lighttpd: before 1.4.33 — fixed in 1.4.33
- Opensuse: 12.2, 12.3, 13.1
How to fix
Upgrade to a fixed version: lighttpd 1.4.33. Check the vendor advisory for mitigations.
References
- http://download.lighttpd.net/lighttpd/security/lighttpd_sa_2013_02.txt
- http://jvn.jp/en/jp/JVN37417423/index.html
- http://lists.opensuse.org/opensuse-updates/2014-01/msg00049.html
- http://marc.info/?l=bugtraq&m=141576815022399&w=2
- http://secunia.com/advisories/55682
- http://www.openwall.com/lists/oss-security/2013/11/12/4
- https://kc.mcafee.com/corporate/index?page=content&id=SB10310
- https://www.debian.org/security/2013/dsa-2795
- http://download.lighttpd.net/lighttpd/security/lighttpd_sa_2013_02.txt
- http://jvn.jp/en/jp/JVN37417423/index.html
- http://lists.opensuse.org/opensuse-updates/2014-01/msg00049.html
- http://marc.info/?l=bugtraq&m=141576815022399&w=2
Get alerted when CVE-2013-4559 or the next vulnerability affects your stack