What’s Vulnerable › Vulnerabilities
CVE-2013-4560
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2013-11-20 · updated 2026-06-16
- Weakness: CWE-416
Description
Use-after-free vulnerability in lighttpd before 1.4.33 allows remote attackers to cause a denial of service (segmentation fault and crash) via unspecified vectors that trigger FAMMonitorDirectory failures.
Affected products
- Debian Linux: 6.0, 7.0, 8.0
- lighttpd: before 1.4.33 — fixed in 1.4.33
- Opensuse: 12.2, 12.3, 13.1
How to fix
Upgrade to a fixed version: lighttpd 1.4.33. Check the vendor advisory for mitigations.
References
- http://download.lighttpd.net/lighttpd/security/lighttpd_sa_2013_03.txt
- http://jvn.jp/en/jp/JVN37417423/index.html
- http://lists.opensuse.org/opensuse-updates/2014-01/msg00049.html
- http://marc.info/?l=bugtraq&m=141576815022399&w=2
- http://secunia.com/advisories/55682
- http://www.openwall.com/lists/oss-security/2013/11/12/4
- https://www.debian.org/security/2013/dsa-2795
- http://download.lighttpd.net/lighttpd/security/lighttpd_sa_2013_03.txt
- http://jvn.jp/en/jp/JVN37417423/index.html
- http://lists.opensuse.org/opensuse-updates/2014-01/msg00049.html
- http://marc.info/?l=bugtraq&m=141576815022399&w=2
- http://secunia.com/advisories/55682
Get alerted when CVE-2013-4560 or the next vulnerability affects your stack