What’s Vulnerable › Vulnerabilities
CVE-2013-4583
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-28 · updated 2026-06-16
- Weakness: CWE-269
Description
The parse_cmd function in lib/gitlab_shell.rb in GitLab 5.0 before 5.4.2, Community Edition before 6.2.4, and Enterprise Edition before 6.2.1 and gitlab-shell before 1.7.8 allows remote authenticated users to gain privileges and clone arbitrary repositories.
Affected products
- GitLab: from 5.0.0 before 5.4.2; from 6.0.0 before 6.2.1; from 6.0.0 before 6.2.4 — fixed in 5.4.2, 6.2.1, 6.2.4
- gitlab-shell: before 1.7.8 — fixed in 1.7.8
How to fix
Upgrade to a fixed version: GitLab 5.4.2, 6.2.1, 6.2.4; gitlab-shell 1.7.8. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2013/11/15/4
- https://www.gitlab.com/2013/11/14/multiple-critical-vulnerabilities-in-gitlab/
- https://www.openwall.com/lists/oss-security/2013/11/18/4
- http://www.openwall.com/lists/oss-security/2013/11/15/4
- https://www.gitlab.com/2013/11/14/multiple-critical-vulnerabilities-in-gitlab/
- https://www.openwall.com/lists/oss-security/2013/11/18/4
Get alerted when CVE-2013-4583 or the next vulnerability affects your stack