What’s Vulnerable › Vulnerabilities
CVE-2013-4587
- Severity: high (CVSS 7.2 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2013-12-14 · updated 2026-06-16
- Weakness: CWE-20
Description
Array index error in the kvm_vm_ioctl_create_vcpu function in virt/kvm/kvm_main.c in the KVM subsystem in the Linux kernel through 3.12.5 allows local users to gain privileges via a large id value.
Affected products
- Linux kernel: before 3.2.54; from 3.3 before 3.4.75; from 3.5 before 3.10.25; from 3.11 before 3.12.6 — fixed in 3.10.25, 3.12.6, 3.2.54, 3.4.75
- Opensuse: 11.4, 12.3, 13.1
How to fix
Upgrade to a fixed version: Linux kernel 3.10.25, 3.12.6, 3.2.54, 3.4.75. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=338c7dbadd2671189cec7faf64c84d01071b3f96
- http://lists.opensuse.org/opensuse-security-announce/2014-02/msg00002.html
- http://lists.opensuse.org/opensuse-security-announce/2014-02/msg00003.html
- http://lists.opensuse.org/opensuse-updates/2014-02/msg00045.html
- http://www.openwall.com/lists/oss-security/2013/12/12/12
- http://www.ubuntu.com/usn/USN-2109-1
- http://www.ubuntu.com/usn/USN-2110-1
- http://www.ubuntu.com/usn/USN-2113-1
- http://www.ubuntu.com/usn/USN-2117-1
- http://www.ubuntu.com/usn/USN-2128-1
- http://www.ubuntu.com/usn/USN-2129-1
- http://www.ubuntu.com/usn/USN-2135-1
Get alerted when CVE-2013-4587 or the next vulnerability affects your stack