What’s Vulnerable › Vulnerabilities
CVE-2013-5619
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2013-12-11 · updated 2026-06-16
- Weakness: CWE-190
Description
Multiple integer overflows in the binary-search implementation in SpiderMonkey in Mozilla Firefox before 26.0 and SeaMonkey before 2.23 might allow remote attackers to cause a denial of service (out-of-bounds array access) or possibly have unspecified other impact via crafted JavaScript code.
Affected products
- Canonical Ubuntu Linux: 12.04, 12.10, 13.04, 13.10
- Fedoraproject Fedora: 19, 20
- Mozilla Firefox: before 26.0 — fixed in 26.0
- Mozilla Seamonkey: before 2.23 — fixed in 2.23
- Opensuse: 12.2, 13.1
- Oracle Corporation Solaris Operating System: 11.3
- SUSE Linux Enterprise Server 15 SP1: 11-sp3
- SUSE Linux Enterprise Server: 11-sp3
- SUSE Linux Enterprise Software Development Kit: 11-sp3
How to fix
Upgrade to a fixed version: Mozilla Firefox 26.0; Mozilla Seamonkey 2.23. Check the vendor advisory for mitigations.
References
- http://lists.fedoraproject.org/pipermail/package-announce/2013-December/123437.html
- http://lists.fedoraproject.org/pipermail/package-announce/2013-December/124257.html
- http://lists.opensuse.org/opensuse-security-announce/2013-12/msg00010.html
- http://lists.opensuse.org/opensuse-updates/2013-12/msg00085.html
- http://lists.opensuse.org/opensuse-updates/2013-12/msg00086.html
- http://lists.opensuse.org/opensuse-updates/2013-12/msg00087.html
- http://lists.opensuse.org/opensuse-updates/2014-01/msg00002.html
- http://www.mozilla.org/security/announce/2013/mfsa2013-110.html
- http://www.oracle.com/technetwork/topics/security/bulletinapr2016-2952098.html
- http://www.securitytracker.com/id/1029470
- http://www.securitytracker.com/id/1029476
- http://www.ubuntu.com/usn/USN-2052-1
Get alerted when CVE-2013-5619 or the next vulnerability affects your stack