What’s Vulnerable › Vulnerabilities

CVE-2013-6282: Linux Kernel Improper Input Validation Vulnerability

Description

The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the v6k and v7 ARM platforms do not validate certain addresses, which allows attackers to read or modify the contents of arbitrary kernel memory locations via a crafted application, as exploited in the wild against Android devices in October and November 2013.

Affected products

How to fix

Upgrade to a fixed version: Linux kernel 3.2.54, 3.4.12, 3.5.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2013-6282 or the next vulnerability affects your stack