What’s Vulnerable › Vulnerabilities
CVE-2013-6370
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2014-04-22 · updated 2026-06-17
- Weakness: CWE-119
Description
Buffer overflow in the printbuf APIs in json-c before 0.12 allows remote attackers to cause a denial of service via unspecified vectors.
Affected products
- Fedoraproject Fedora: 20
- Json-C: before 0.12-20140410 — fixed in 0.12-20140410
How to fix
Upgrade to a fixed version: Json-C 0.12-20140410. Check the vendor advisory for mitigations.
References
- http://lists.fedoraproject.org/pipermail/package-announce/2014-April/131845.html
- http://secunia.com/advisories/57791
- http://www.mandriva.com/security/advisories?name=MDVSA-2014:079
- http://www.oracle.com/technetwork/topics/security/bulletinoct2015-2511968.html
- http://www.securityfocus.com/bid/66720
- https://bugzilla.redhat.com/show_bug.cgi?id=1032322
- https://exchange.xforce.ibmcloud.com/vulnerabilities/92540
- https://github.com/json-c/json-c/commit/64e36901a0614bf64a19bc3396469c66dcd0b015
- http://lists.fedoraproject.org/pipermail/package-announce/2014-April/131845.html
- http://secunia.com/advisories/57791
- http://www.mandriva.com/security/advisories?name=MDVSA-2014:079
- http://www.oracle.com/technetwork/topics/security/bulletinoct2015-2511968.html
Get alerted when CVE-2013-6370 or the next vulnerability affects your stack