What’s Vulnerable › Vulnerabilities
CVE-2013-6383
- Severity: medium (CVSS 6.9 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2013-11-27 · updated 2026-06-17
- Weakness: CWE-264
Description
The aac_compat_ioctl function in drivers/scsi/aacraid/linit.c in the Linux kernel before 3.11.8 does not require the CAP_SYS_RAWIO capability, which allows local users to bypass intended access restrictions via a crafted ioctl call.
Affected products
- Linux kernel: from 2.6.12 before 3.2.53; from 3.3 before 3.4.69; from 3.5 before 3.10.19; from 3.11 before 3.11.8 — fixed in 3.10.19, 3.11.8, 3.2.53, 3.4.69
How to fix
Upgrade to a fixed version: Linux kernel 3.10.19, 3.11.8, 3.2.53, 3.4.69. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=f856567b930dfcdbc3323261bf77240ccdde01f5
- http://rhn.redhat.com/errata/RHSA-2014-0100.html
- http://rhn.redhat.com/errata/RHSA-2014-0285.html
- http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.11.8
- http://www.openwall.com/lists/oss-security/2013/11/22/5
- http://www.ubuntu.com/usn/USN-2066-1
- http://www.ubuntu.com/usn/USN-2067-1
- http://www.ubuntu.com/usn/USN-2068-1
- http://www.ubuntu.com/usn/USN-2069-1
- http://www.ubuntu.com/usn/USN-2070-1
- http://www.ubuntu.com/usn/USN-2071-1
- http://www.ubuntu.com/usn/USN-2072-1
Get alerted when CVE-2013-6383 or the next vulnerability affects your stack