What’s Vulnerable › Vulnerabilities
CVE-2013-6424
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2014-01-18 · updated 2026-06-17
- Weakness: CWE-191
Description
Integer underflow in the xTrapezoidValid macro in render/picture.h in X.Org allows context-dependent attackers to cause a denial of service (crash) via a negative bottom value.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 14.10
- Debian Linux: 6.0, 7.0
- Opensuse: 12.2, 12.3, 13.1
- The pixman Project pixman: before 0.31.2 — fixed in 0.31.2
How to fix
Upgrade to a fixed version: The pixman Project pixman 0.31.2. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-updates/2013-12/msg00127.html
- http://lists.x.org/archives/xorg-devel/2013-October/037996.html
- http://rhn.redhat.com/errata/RHSA-2013-1868.html
- http://www.debian.org/security/2013/dsa-2822
- http://www.openwall.com/lists/oss-security/2013/12/03/8
- http://www.openwall.com/lists/oss-security/2013/12/04/8
- http://www.ubuntu.com/usn/USN-2500-1
- https://bugs.freedesktop.org/show_bug.cgi?id=67484
- https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/1197921
- https://security.gentoo.org/glsa/201701-64
- https://security.gentoo.org/glsa/201710-30
- http://lists.opensuse.org/opensuse-updates/2013-12/msg00127.html
Get alerted when CVE-2013-6424 or the next vulnerability affects your stack