What’s Vulnerable › Vulnerabilities
CVE-2013-6425
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2014-01-18 · updated 2026-06-17
- Weakness: CWE-191
Description
Integer underflow in the pixman_trapezoid_valid macro in pixman.h in Pixman before 0.32.0, as used in X.Org server and cairo, allows context-dependent attackers to cause a denial of service (crash) via a negative bottom value.
Affected products
- Canonical Ubuntu Linux: 12.04, 12.10, 13.04, 13.10
- Debian Linux: 6.0, 7.0
- Opensuse: 11.4, 12.2, 12.3, 13.1
- The pixman Project pixman: before 0.32.0 — fixed in 0.32.0
- RedHat Enterprise Linux Desktop: 5.0, 6.0
- RedHat Enterprise Linux Eus: 6.5
- RedHat Enterprise Linux Server: 5.0, 6.0
- RedHat Enterprise Linux Server Aus: 6.5
- RedHat Enterprise Linux Server Tus: 6.5
- RedHat Enterprise Linux Workstation: 5.0, 6.0
How to fix
Upgrade to a fixed version: The pixman Project pixman 0.32.0. Check the vendor advisory for mitigations.
References
- http://cgit.freedesktop.org/pixman/commit/?id=5e14da97f16e421d084a9e735be21b1025150f0c
- http://lists.freedesktop.org/archives/pixman/2013-November/003109.html
- http://lists.opensuse.org/opensuse-updates/2014-01/msg00001.html
- http://lists.opensuse.org/opensuse-updates/2014-01/msg00005.html
- http://lists.opensuse.org/opensuse-updates/2014-01/msg00008.html
- http://lists.opensuse.org/opensuse-updates/2014-01/msg00097.html
- http://rhn.redhat.com/errata/RHSA-2013-1869.html
- http://www.debian.org/security/2013/dsa-2823
- http://www.openwall.com/lists/oss-security/2013/12/03/8
- http://www.openwall.com/lists/oss-security/2013/12/04/8
- http://www.ubuntu.com/usn/USN-2047-1
- https://bugs.freedesktop.org/show_bug.cgi?id=67484
Get alerted when CVE-2013-6425 or the next vulnerability affects your stack