What’s Vulnerable › Vulnerabilities
CVE-2013-6451
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-28 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability in MediaWiki 1.19.9 before 1.19.10, 1.2x before 1.21.4, and 1.22.x before 1.22.1 allows remote attackers to inject arbitrary web script or HTML via unspecified CSS values.
Affected products
- Wikimedia Foundation MediaWiki: from 1.19.9 before 1.19.10; from 1.20.0 before 1.21.4; from 1.22.0 before 1.22.1 — fixed in 1.19.10, 1.21.4, 1.22.1
How to fix
Upgrade to a fixed version: Wikimedia Foundation MediaWiki 1.19.10, 1.21.4, 1.22.1. Check the vendor advisory for mitigations.
References
- http://lists.wikimedia.org/pipermail/mediawiki-announce/2014-January/000138.html
- http://lists.wikimedia.org/pipermail/mediawiki-announce/2014-January/000138.html
Get alerted when CVE-2013-6451 or the next vulnerability affects your stack