What’s Vulnerable › Vulnerabilities

CVE-2013-6712

Description

The scan function in ext/date/lib/parse_iso_intervals.c in PHP through 5.5.6 does not properly restrict creation of DateInterval objects, which might allow remote attackers to cause a denial of service (heap-based buffer over-read) via a crafted interval specification.

Affected products

How to fix

Upgrade to a fixed version: PHP 5.3.29, 5.4.24, 5.5.8. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2013-6712 or the next vulnerability affects your stack