What’s Vulnerable › Vulnerabilities
CVE-2013-7071
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-12-31 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability in the handle_request function in lib/HTTPServer.pm in Monitorix before 3.4.0 allows remote attackers to inject arbitrary web script or HTML via the PATH_INFO.
Affected products
- Fibranet Monitorix: before 3.4.0 — fixed in 3.4.0
How to fix
Upgrade to a fixed version: Fibranet Monitorix 3.4.0. Check the vendor advisory for mitigations.
References
- http://openwall.com/lists/oss-security/2013/12/12/8
- https://github.com/mikaku/Monitorix/commit/e86c11593238be6956a67a04d640c65810d50b59
- https://github.com/mikaku/Monitorix/issues/30
- http://openwall.com/lists/oss-security/2013/12/12/8
- https://github.com/mikaku/Monitorix/commit/e86c11593238be6956a67a04d640c65810d50b59
- https://github.com/mikaku/Monitorix/issues/30
Get alerted when CVE-2013-7071 or the next vulnerability affects your stack