What’s Vulnerable › Vulnerabilities
CVE-2013-7370
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-12-11 · updated 2026-06-17
- Weakness: CWE-79
Description
node-connect before 2.8.1 has XSS in the Sencha Labs Connect middleware
Affected products
- Debian Linux: 8.0, 9.0, 10.0
- Opensuse: 13.1
- Openshift: 2.0
- HackerOne connect node module: before 2.8.1 — fixed in 2.8.1
How to fix
Upgrade to a fixed version: HackerOne connect node module 2.8.1. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2014/04/21/2
- http://www.openwall.com/lists/oss-security/2014/05/13/1
- https://access.redhat.com/security/cve/cve-2013-7370
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2013-7370
- https://bugzilla.suse.com/show_bug.cgi?id=CVE-2013-7370
- https://nodesecurity.io/advisories/methodOverride_Middleware_Reflected_Cross-Site_Scripting
- https://security-tracker.debian.org/tracker/CVE-2013-7370
- http://www.openwall.com/lists/oss-security/2014/04/21/2
- http://www.openwall.com/lists/oss-security/2014/05/13/1
- https://access.redhat.com/security/cve/cve-2013-7370
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2013-7370
- https://bugzilla.suse.com/show_bug.cgi?id=CVE-2013-7370
Get alerted when CVE-2013-7370 or the next vulnerability affects your stack