What’s Vulnerable › Vulnerabilities
CVE-2013-7381
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-02-12 · updated 2026-06-17
- Weakness: CWE-74
Description
libnotify before 1.0.4 for Node.js allows remote attackers to execute arbitrary commands via unspecified characters in a call to libnotify.notify.
Affected products
- Libnotify Project Libnotify: before 1.0.4 — fixed in 1.0.4
How to fix
Upgrade to a fixed version: Libnotify Project Libnotify 1.0.4. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2014/05/13/1
- http://www.openwall.com/lists/oss-security/2014/05/15/2
- https://github.com/mytrile/node-libnotify/commit/dfe7801d73a0dda10663a0ff3d0ec8b4d5f0d448
- https://nodesecurity.io/advisories/libnotify_potential_command_injection_in_libnotify.notify
- http://www.openwall.com/lists/oss-security/2014/05/13/1
- http://www.openwall.com/lists/oss-security/2014/05/15/2
- https://github.com/mytrile/node-libnotify/commit/dfe7801d73a0dda10663a0ff3d0ec8b4d5f0d448
- https://nodesecurity.io/advisories/libnotify_potential_command_injection_in_libnotify.notify
Get alerted when CVE-2013-7381 or the next vulnerability affects your stack