What’s Vulnerable › Vulnerabilities
CVE-2014-0011
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-02 · updated 2026-06-17
- Weakness: CWE-787
Description
Multiple heap-based buffer overflows in the ZRLE_DECODE function in common/rfb/zrleDecode.h in TigerVNC before 1.3.1, when NDEBUG is enabled, allow remote VNC servers to cause a denial of service (vncviewer crash) and possibly execute arbitrary code via vectors related to screen image rendering.
Affected products
- Kaspersky TigerVNC: before 1.3.1 — fixed in 1.3.1
How to fix
Upgrade to a fixed version: Kaspersky TigerVNC 1.3.1. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1050928
- https://github.com/TigerVNC/tigervnc/releases/tag/v1.3.1
- https://bugzilla.redhat.com/show_bug.cgi?id=1050928
- https://github.com/TigerVNC/tigervnc/releases/tag/v1.3.1
Get alerted when CVE-2014-0011 or the next vulnerability affects your stack