What’s Vulnerable › Vulnerabilities
CVE-2014-0077
- Severity: medium (CVSS 5.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2014-04-14 · updated 2026-06-17
- Weakness: CWE-787
Description
drivers/vhost/net.c in the Linux kernel before 3.13.10, when mergeable buffers are disabled, does not properly validate packet lengths, which allows guest OS users to cause a denial of service (memory corruption and host OS crash) or possibly gain privileges on the host OS via crafted packets, related to the handle_rx and get_rx_bufs functions.
Affected products
- Linux kernel: before 3.13.10 — fixed in 3.13.10
How to fix
Upgrade to a fixed version: Linux kernel 3.13.10. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=d8316f3991d207fe32881a9ac20241be8fa2bad0
- http://secunia.com/advisories/59386
- http://secunia.com/advisories/59599
- http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.13.10
- http://www.securityfocus.com/bid/66678
- https://bugzilla.redhat.com/show_bug.cgi?id=1064440
- https://github.com/torvalds/linux/commit/d8316f3991d207fe32881a9ac20241be8fa2bad0
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=d8316f3991d207fe32881a9ac20241be8fa2bad0
- http://secunia.com/advisories/59386
- http://secunia.com/advisories/59599
- http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.13.10
- http://www.securityfocus.com/bid/66678
Get alerted when CVE-2014-0077 or the next vulnerability affects your stack