What’s Vulnerable › Vulnerabilities
CVE-2014-0094
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 99.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2014-03-11 · updated 2026-06-17
Description
The ParametersInterceptor in Apache Struts before 2.3.16.2 allows remote attackers to "manipulate" the ClassLoader via the class parameter, which is passed to the getClass method.
Affected products
- Apache Struts: from 2.0.0 before 2.3.16.1 — fixed in 2.3.16.1
How to fix
Upgrade to a fixed version: Apache Struts 2.3.16.1. Check the vendor advisory for mitigations.
References
- http://jvn.jp/en/jp/JVN19294237/index.html
- http://jvndb.jvn.jp/jvndb/JVNDB-2014-000045
- http://packetstormsecurity.com/files/127215/VMware-Security-Advisory-2014-0007.html
- http://secunia.com/advisories/56440
- http://secunia.com/advisories/59178
- http://struts.apache.org/release/2.3.x/docs/s2-020.html
- http://www-01.ibm.com/support/docview.wss?uid=swg21676706
- http://www.huawei.com/en/security/psirt/security-bulletins/security-advisories/hw-350733.htm
- http://www.konakart.com/downloads/ver-7-3-0-0-whats-new
- http://www.oracle.com/technetwork/topics/security/cpuapr2015-2365600.html
- http://www.securityfocus.com/archive/1/531362/100/0/threaded
- http://www.securityfocus.com/archive/1/532549/100/0/threaded
Get alerted when CVE-2014-0094 or the next vulnerability affects your stack